Takahashi EM-1S RA Drive Analysis and Southern Hemisphere Modification

I had a look at the innards of the Takahashi EM-1S RA drive, because I wanted to see how hard it would be to convert it to center-positive. Quick answer: it's hard.

A second problem was how to use the EM-1S in the Southern hemisphere. Here is the outside of the EM-1S RA drive panel. It is obvious that there is no way to switch from northern to southern hemisphere tracking:

Inside, we see a Sanryusha P43G stepper motor with 24 pulses per revolution and a 1:500 gearbox. This is the same motor in my EM-11 Temma2 Jr. and presumably many other Takahashi mounts.

The circuit is fairly simple but full of obsolete components.

We see the following IC's:
  • IC1: OKI M5562, Google is not very helpful, but most likely this is a clock generator IC
  • IC2: Toshiba TC4013BP, dual D-type flip flop, probably the logic generator for the stepping waveform
  • IC3: TDG2004, my immediate guess was this is a variant of the ULN2004 stepper motor driver
Supposedly, there is a switch on the board to enable southern hemisphere tracking, but there is no such switch here. It's fairly apparent that in order to make this mount useful in the southern hemisphere, the wires from the motor to the ULN2004 will have to be switched around - a highly annoying chore.

With some tracing, we can determine that the topmost two wires from the motor are the commons (the motor is a 6-wire unipolar with split center tap) and the other four wires are the four phases.

Therefore, it should be possible to reverse the direction of rotation by swapping the four wires that go to pins 13, 14, 15, and 16 of the TDG2004.

To be more specific, assuming a stepping sequence of 1-2-3-4 (where the white wire from the motor is 1, blue is 2, black is 3, and yellow is 4) the motor should run in reverse with a stepping sequence of 4-3-2-1. In other words, swap 1 and 4, and 2 and 3.

To make this process simpler and avoid multiple soldering and de-soldering chores, I soldered some Berg pins to the board, and attached connectors to the motor wires. After some challenges (the #2 connection broke which prevented the motor from turning) I was able to validate that indeed, the motor now runs in reverse.

No comments: